设为首页 - 收藏本站 欢迎访问: 股粉帮(www.guofenb.com) - 免费下载通达信大智慧等股票公式,指标,股池并进行投资交流!交流QQ群:891842347
热搜: 选股副图主图文华公式
当前位置:首页 >>公式股池 >>其它公式 >> 金字塔暴涨策略指标源码

金字塔暴涨策略指标源码

2020年09月06日 [其它公式] 浏览:61 评论:0

金字塔暴涨策略指标源码:

生命线:MA(CLOSE,26),COLORRED,LINETHICK2;
STICKLINE(C>=生命线 AND C>=O,C,O,7,0),COLORRED;
STICKLINE(C>=生命线 AND C>=O,H,L,0,0),COLORRED;
dp:=if(c=INDEXC,0,1);
gj:=AMOUNT/v/100 ;
多头线:EMA(C,1.5),COLORYELLOW;
空头线:EMA(C,5),COLOR00FF00;
均衡线:EMA(空头线,5),COLORWHITE;
varF1:=COUNT(CROSS(多头线,均衡线),2)=1;
varF2:=COUNT(CROSS(空头线,均衡线),2)=1;
ZAI:=FILTER(varF1 AND varF2,2);
DRAWTEXT(ZAI,均衡线*0.98,\' 主力拉升\'),color00ff00;
mtm:=close-ref(close,1);
dx:=100*ema(ema(mtm,6),6)/ema(ema(abs(mtm),6),6);
dy:=hhv(dx,2)=hhv(dx,7) and count(dx>50,2) and cross(ma(dx,2),dx);
lc:=ref(close,1);
rsi:=sma(max(close-lc,0),6,1)/sma(abs(close-lc),6,1)*100;
ZDF:=(C-REF(C,1))/REF(C,1)*100;
STICKLINE(ZDF>9.8,O,C,6,0),COLORRED;
STICKLINE(ZDF<-9.8,O,C,6,0),COLORBLUE;
白买进:0,colorwhite,LINETHICK0;
黄加仓:0,coloryellow,LINETHICK0 ;
蓝跌:0,colorblue,LINETHICK0;
绿见顶:0,colorgreen,LINETHICK0;
粗红强势:0,colorred,LINETHICK0;
红蓝调整:0,colorred,LINETHICK0;
VAR1:=(100 - ((90 * (HHV(HIGH,21) - CLOSE)) / (HHV(HIGH,21) - LLV(LOW,21))));
VAR2:=(100 - ((90 * (HHV(HIGH,21) - CLOSE)) / (HHV(HIGH,21) - LLV(LOW,21))));
VAR3:=(100 - MA(((100 * (HHV(HIGH,6) - CLOSE)) / (HHV(HIGH,6) - LLV(LOW,6))),34));
DRAWICON(CROSS(VAR2,MA(VAR3,6)),(LOW * 0.998),8);
DRAWICON(CROSS(MA(VAR3,6),VAR1),(HIGH * 1.013),9);
DRAWTEXT(CROSS(VAR2,MA(VAR3,6)),(LOW * 0.984),\'买 \'),color4440FF;
DRAWTEXT(CROSS(MA(VAR3,6),VAR1),(HIGH * 1.035),\'卖 \'),colorFFFF34;
Vare1:=EMA(C,3);
Vare2:=EMA(C,5);
Vare3:=EMA(C,10);
Var4:=EMA(C,20);
Var5:=EMA(C,30);Var6:=(Var2+Var3+Var4+Var5)/4;
Var7:=(Var6-REF(Var6,15))/REF(Var6,15)*100;
Var8:=(Var6-REF(Var6,15))/REF(Var6, 15)*100;
Var9:=EMA(Var7,8);
STICKLINE(Var7<1*REF(Var7,1),h,l,0.5,0),COLORBLUE;
STICKLINE(Var7<1*REF(Var7,1),o,c,5,1),COLORBLUE;
STICKLINE(Var7>1*REF(Var7,1),h,l,0.5,0),COLORRED;
STICKLINE(Var7>1*REF(Var7,1),o,c,5, 1),COLORRED;
STICKLINE(Var7<1*REF(Var7,1) AND Var9>1*REF(Var9,1),h,l,0.5,0),COLORGREEN;
STICKLINE(Var7<1*REF(Var7,1) AND Var9>1*REF(Var9,1),o,c,5,1),COLORGREEN;
买进价:=((c-ref(ma(c,6),1))/6+ma(c,6))*1.004;
买进条件:=cross(c,买进价) and 买进价>ref(买进价,1);
STICKLINE(买进条件,h,l,0.5,1),colorwhite,linethick2;
STICKLINE(买进条件,o,c,6,0),colorwhite,linethick2;
加码价:=((c-ref(ma(c,18),1))/18+ma(c,18))*1.004;
加码条件:=cross(c,加码价) and 加码价>ref(加码价,1);
STICKLINE(加码条件,h,l,0.5,1),coloryellow,linethick2;
STICKLINE(加码条件,o,c,6,0),coloryellow,linethick2;

(编辑:股粉帮)

发表我的评论换个身份
取消评论

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址
热评文章
二维码