设为首页 - 收藏本站 欢迎访问: 股粉帮(www.guofenb.com) - 免费下载通达信大智慧等股票公式,指标,股池并进行投资交流!交流QQ群:891842347
热搜: 选股副图主图文华公式
当前位置:首页 >>公式股池 >>通达信公式 >> 通达信短线多空顶底止盈止损副图指标公式

通达信短线多空顶底止盈止损副图指标公式

2020年10月31日 [通达信公式] 浏览:206 评论:0
通达信短线多空顶底止盈止损副图指标公式:
多头止损:XMA(XMA(L,25),25)-(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*3.5,LINETHICK0,coloryellow;
多头止盈:(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*1+XMA(XMA(H,25),25),LINETHICK0,colorwhite;
空头止损:(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*3.5+XMA(XMA(H,25),25),LINETHICK0,coloryellow;
多头入场:XMA(XMA(L,25),25)-(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*1,LINETHICK0,colorwhite;
短线高点H:=(20*H+19*REF(H,1)+18*REF(H,2)+17*REF(H,3)+16*REF(H,4)+15*REF(H,5)+14*REF(H,6)
+13*REF(H,7)+12*REF(H,8)+11*REF(H,9)+10*REF(H,10)+9*REF(H,11)+8*REF(H,12)
+7*REF(H,13)+6*REF(H,14)+5*REF(H,15)+4*REF(H,16)+3*REF(H,17)+2*REF(H,18)+
REF(H,20))/210,colorblue,LINETHICK1;
短线低点L:=(20*L+19*REF(L,1)+18*REF(L,2)+17*REF(L,3)+16*REF(L,4)+15*REF(L,5)+14*REF(L,6)
+13*REF(L,7)+12*REF(L,8)+11*REF(L,9)+10*REF(L,10)+9*REF(L,11)+8*REF(L,12)
+7*REF(L,13)+6*REF(L,14)+5*REF(L,15)+4*REF(L,16)+3*REF(L,17)+2*REF(L,18)+
REF(L,20))/210,colorblue,LINETHICK1;
D90H:=EMA(短线高点H,90),colorred,LINETHICK1;
D90L:=EMA(短线低点L,90),colorred,LINETHICK1;
D90差:=D90H-D90L;
D90顶:=D90H+D90差*2,colorred,LINETHICK1;
D90底:=D90L-D90差*2,colorred,LINETHICK1;
高0:=(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*1+XMA(XMA(H,25),25),LINETHICK1,colorwhite;
低0:=XMA(XMA(L,25),25)-(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*1,LINETHICK1,colorwhite;
多头定位:=低0>=D90底 AND 高0>=D90顶;
空头定位:=高0<=D90顶 AND 低0<=D90底;
震荡定位:=低0>=D90底 AND 高0<=D90顶;
短线顶:=(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*2+XMA(XMA(H,25),25),LINETHICK2,colorgreen;
短线底:=XMA(XMA(L,25),25)-(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*2,LINETHICK2,colorgreen;
短线收盘:=(C-短线底)/(短线顶-短线底)*100000,LINETHICK2,colorred;
短线开盘:=(O-短线底)/(短线顶-短线底)*100000,LINETHICK2,colorred;
短期高盘:=(H-短线底)/(短线顶-短线底)*100000,LINETHICK2,colorred;
短期低盘:=(L-短线底)/(短线顶-短线底)*100000,LINETHICK0,colorred;
顶1:=110000,coloryellow,LINETHICK0;
底1:=-10000,coloryellow,LINETHICK0;
STICKLINE(多头定位=1,顶1,底1,5,0),COLOR000066;
STICKLINE(空头定位=1,顶1,底1,5,0),COLOR003300;
STICKLINE(震荡定位=1,顶1,底1,5,0),COLOR555555;
震荡顶部:=(XMA(XMA(短期高盘,25),25)-XMA(XMA(短期低盘,25),25))*1+XMA(XMA(短期高盘,25),25),DOTLINE,colorwhite;
震荡底部:=XMA(XMA(短期低盘,25),25)-(XMA(XMA(短期高盘,25),25)-XMA(XMA(短期低盘,25),25))*1,DOTLINE,colorwhite;
做空:80000,colorwhite,LINETHICK1;
做多:20000,colorwhite,LINETHICK1;
空损:110000,colormagenta,LINETHICK2;
多损:-10000,colormagenta,LINETHICK2;
DRAWTEXT(ISLASTBAR,108000,'顶'),colormagenta;
DRAWTEXT(ISLASTBAR,80000,'卖'),colorgreen;
DRAWTEXT(ISLASTBAR,20000,'买'),colorred;
DRAWTEXT(ISLASTBAR,-9000,'底'),colormagenta;
BSB:=EMA((CLOSE+HIGH+LOW)/3,3);
BSM:=EMA(SLOPE((CLOSE+HIGH+LOW)/3,24)*20+(CLOSE+HIGH+LOW)/3,48),POINTDOT,coloryellow;
STICKLINE(BSB>=BSM,短期低盘,短期高盘,0.0,0),colorred;
STICKLINE(BSB>=BSM,短线收盘,短线开盘,3,1),colorred;
STICKLINE(BSB<=BSM,短期低盘,短期高盘,0.0,0),colorgreen;
STICKLINE(BSB<=BSM,短线收盘,短线开盘,3,1),colorgreen;
白色点多定位1:=短期低盘<做多 AND 短期高盘>做多;
白色点空定位1:=短期高盘>做空 AND 短期低盘<做空;
STICKLINE(白色点多定位1=1,短期低盘,做多,3,0),colorwhite;
STICKLINE(白色点空定位1=1,短期高盘,做空,3,0),colorwhite;
白色点多定位2:=短期高盘<做多;
白色点空定位2:=短期低盘>做空;
STICKLINE(白色点多定位2=1,短期低盘,短期高盘,0.0,0),colorwhite;
STICKLINE(白色点多定位2=1,短线收盘,短线开盘,3,0),colorwhite;
STICKLINE(白色点空定位2=1,短期低盘,短期高盘,0.0,0),colorwhite;
STICKLINE(白色点空定位2=1,短线收盘,短线开盘,3,0),colorwhite;
多头多定位:=CROSS(做多,短期低盘) AND 多头定位=1;
多头平定位:=CROSS(短期高盘,做空) AND 多头定位=1 AND 震荡定位=0;
空头空定位:=CROSS(短期高盘,做空) AND 空头定位=1;
空头平定位:=CROSS(做多,短期低盘) AND 空头定位=1 AND 震荡定位=0;
震荡多定位:=CROSS(做多,短期低盘) AND 震荡定位=1;
震荡空定位:=CROSS(短期高盘,做空) AND 震荡定位=1;
DRAWICON(空头平定位=1,短期低盘,5);
DRAWICON(多头平定位=1,短期高盘,6);
DRAWICON(多头多定位=1 OR 震荡多定位=1,短期低盘,7);
DRAWICON(空头空定位=1 OR 震荡空定位=1,短期高盘,8);

0003_meitu_2.jpg

(编辑:股粉帮)

发表我的评论换个身份
取消评论

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址
热评文章
二维码